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Galaxy: UTS Knowledge
Management System
Introduction
The Galaxy Knowledge Management System goes beyond documents and email. With Galaxy, you can develop
and deploy calculations as enterprise solutions. UTS developed Galaxy as a secure, efficient, and easy-to-use
solution for companies struggling to manage and capitalize on their calculation-based knowledge. Calculations
come in a variety of proprietary formats. Galaxy transforms these calculations—including those created using
tools like Excel, C++, TK Solver and others—for deployment to authorized users, with virtually no
programming required.
A cache of expertise, known collectively as “corporate knowledge” exists within every organization. Every day,
engineers, analysts and developers use a wide variety of tools to create calculations, for a range of uses both in
and outside the company. Previously, these calculations might have existed only in seclusion on the hard drives
or in the illegible notes of a few company experts. The challenge of managing these calculations includes:





Quality Assurance
Security of Intellectual Property
Ease of Use
Distribution

Galaxy lets you further enhance your calculations by providing the tools to build a custom-designed Graphical
User Interface (GUI), add relevant documents, manuals, CAD files, and salient website information, all without
any programming.

System Requirements
For Galaxy:





.NET framework 3.5
TK Solver Build #143
Windows XP or higher
Office 2007 or higher

To use Galaxy with Word:


TK Solver Report Tool

To use Galaxy with Excel:


Excel Add-in
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Developing a Galaxy Application
Using a TK Solver Model
Preparing the TK Model for Galaxy Application
TK Solver Model setup
Before you are ready to create a Galaxy Application, you must first create and save a TK Solver model. When
creating a TK Solver model that will be used in a Galaxy Application there are many things to consider that will
make developing your application easier. For more information on this, please see the TK Solver
documentation Appendix E “Developing Applications Using TK”.

Solution Optimizer
Galaxy applications can take advantage of the Optimizer functions of TK Solver. For more information on
using the Optimizer in TK Solver, please see the TK Solver documentation Chapter 7 “Solution Optimizer”.

Log into Galaxy
Enter your User Name and Password and click “OK”.
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Creating a New TK Solver Application
On the Development menu, choose “Create New TK Solver Model Application”.

The following is the Add TK Solver model Screen:
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Application Group
Choose your application group from the dropdown list.

New Application
Application Name:
Description:

Name your application.
Give a brief description for your application.

Existing Application
If the TK Solver model used to create an application has changed, use the “Existing Application” radio button.

Application Code
Click the “Application Code” link to select the desired System, Sector, Performance Attributes nad Attribute
Domains.

Version Number
Version number is automatically filled in. It can be adjusted manually by clicking on the up or down arrows.

Note: If “Existing Application” under the “Application Group” is selected, checking the “Copy Prev Data”
checkbox will import all scenarios, documents and forms from the previous application.
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Version Details
Add the version details. If there will be several versions of the application, it may be helpful to have notes
regarding the current version.

TK Solver Application Load
Click the Browse button to navigate to the TK Solver model to be used.

The TK Solver model opens in TK Solver. Now the TK Solver area is loaded in Galaxy.

Create Application
Click the “Create Application” Button.
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Scenarios
A scenario is a collection of Forms and Reports. Different scenarios can contain different Forms and Reports.
We will discuss adding Forms and Reports later in the chapter.
A default scenario is created when the application was created. This scenario can be edited or deleted.
Additional scenarios can also be added.

Add a new scenario by clicking the “Add” button. Your scenario can be created using the Galaxy
Studio application or you can use an .EXE file that was previously created in Visual Studio. To use an existing
.EXE file, choose the “Custom (Visual Studio)” radio button.
If the “Galaxy Studio” radio button is selected, enter the “Scenario Name” and click the “Add” button.

If the “Custom (Visual Studio)” radio button is selected, click the
button next to “Assembly Name” to
locate the .EXE file. The “Assembly Class Name” field is automatically filled in. When finished click the Add
button.
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The new scenarios now appear in the “Scenarios” list.

Edit a scenario name by clicking the “Edit” button.
Delete a scenario by clicking the “Delete” button.

Document
Documentation for your application can be attached in the Document area. The document must first be added
to the Galaxy library. (Adding documents to the Galaxy library is explained further in the “Add Document to
Library” section on page 48).
To add documentation to your application, click the Add button.
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Search criteria are available to help you find the document you are looking for. Select your criteria (if any) then
click the
button.
The “Search Results” area now shows all documents that have been loaded into the Galaxy library that meet
the criteria specified.
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Locate the desired document in the “Document” area, select desired version of that document in the “Version”
area, then click the
button. When finished adding all documents click the
button.

To remove a document that has been added to your application, click the “Delete” button. Deleting a
document from your application does not delete it from the Library.

Forms
Forms contain pieces of the TK Solver model. You choose which pieces you want to show and you can
arrange them on the forms exactly how you want them.

Add a new form by clicking the “Add” button.
Click the Edit button to make changes to your form. You can also change a Form Title or the
Display Order for an existing form. To make the changes, click “Update & Continue”.
You can delete a form by clicking the “Delete” button.
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Add a Form

Enter the Form Title and the Display Order. The Display Order determines which order the forms appear in
your application.
Click “Add & Continue”. The following screen appears:

Click the

tab at the bottom right to show the properties for the currently selected field.

Click the

tab at the bottom right to show the contents of the TK Solver Model.

Use the checkboxes at the bottom of the “Solver Data” tab to easily select all inputs and/or outputs.
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Tips for creating forms
Add data to your form by clicking the checkbox next to the item in the “Solver Data” tab. Then, right-click in
the “Solver Data” tab and select “Copy Solver Object(s)”.

Now, on the form, right-click and select “Drop Solver Object(s)”. You may check as many pieces as you want
to appear on the form. Variables, Plots, Tables and Lists can all be copied into a form. Variables automatically
come with 3 fields; label (which comes from the “Comment” field of the TK Solver model), value and unit.

Resize the form window by dragging the
bottom edge of the form.

boxes found in lower right corner, along the right side, and on the

Align elements by dragging a box around them (or individually click each one while holding the CRTL key)
and selecting one of the alignment icons.
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Delete an element by right clicking on an element and selecting “Delete”.
Layer elements by right clicking on an element and selecting “Bring to Front” or “Send to Back” or by using
the layering icons on the toolbar.

A groupbox can be added around groups of elements by clicking on the “GroupBox” item in the Toolbox.
Grouping elements keeps them together when moving. When a groupbox is deleted all of the elements in the
group are deleted also.
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You can change the properties of any element using the “Properties” tab.

You can add Groupboxes, Labels, Tabs and other elements from the Toolbox toolbar.

Periodically save your work by clicking the
the

button. When you are done editing the form, click

button.
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Selecting Multiple Form Elements
Several form elements can be moved or resized at once by selecting multiple elements and making the change
to all selected elements.
To select multiple form elements you can either click on each element while holding the SHIFT or the CTRL
key. Also you can click and drag a rectangle around multiple boxes. When using this method, be sure your
rectangle does not overlap any elements you do not wish to include. Sometimes it is helpful to start your
rectangle well outside of the elements you wish to select.
For example, the screenshots below shows a selection rectangle that starts on the right side of the third column
and stops before the beginning of the middle column of elements. The next screenshot shows that those
middle column elements were included in the selection rectangle and are now selected.

In the next example, the selection rectangle starts from the right side again but stops well before the beginning
of the middle column of elements. What we don’t see though is the “white space” at the end of the first
column elements are actually included in the selection area. As you can see in the next screenshot we have
inadvertently selection the first column of elements also.
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UTS Form Elements
There are 7 UTS elements that can be inserted into a Galaxy form. Following is a summary of some of the
properties of these elements.
UTSCheckbox

Properties of interest are:

ValueChecked: the associated value when the state of
the control is checked
ValueUnChecked: the associated value when the state
of the control is unchecked
VariableName: the associated TK/Excel variable
name persisting values in two states
(checked/unchecked)
VariableType: as usual

UTSComboBox

Properties of interest are:

DisplayList: [TK ListName] the list values that will be
used as a combobox display items
ValueList [TK ListName] the list values that will be
used as a combobox value items
VariableName: associated list name in TK/Excel
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UTSDataGrid

Properties of interest are:

TableName: name of the TK table
TableType: [horizontal/vertical] for TK table types

UTSLabel

Properties of interest are:

VariableName: for showing the appropriate unit
associated with the particular variable
VariableType: solver/form as usual
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UTSPictureBox

Properties of interest are:

PlotName: the name of chart/plot in TK and Excel
application to display at runtime

UTSRadioButton

Properties of interest are:

VariableName: the associated TK/Excel variable
name persisting values in two states
(checked/unchecked)
VariableType: as usual
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UTSTextBox

Properties of interest are:

SysMaxValue: defines the upper bound of TK/Excel
variable
SysMinValue: defines the lower bound of TK/Excel
variable
TextType: defines various input/output of variables
(ex: integer, real, string)
VariabelStatus: ex: input, output
VariabelType: as usual
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Reports
Reports are created using data from your application.

Click the Add button to add a report.
Click the Edit button to make changes to your report. You can also change a Form Title or the
Display Order for an existing form.
You can delete a report by clicking the “Delete” button.

Add a Word Report

Choose “General” or “Comparison” for a report generated using Microsoft Word.
If a “Word Report Type” is selected, a Word Template must be created previously and selected by clicking on
the
button. See the section titled “Create a Word Template for Galaxy Report” on page 23 of this manual.
Click the “Add” button.
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Create a Word Template for Galaxy Report
Open a new blank document in Microsoft Word. Go to the “TK Solver Report” tab and click on the TK
Solver Report Tool icon.

Click the browse button

and select the TK Solver model you will be creating the template for.

Click
You can add TK Solver variables, plots, tables and lists. To add a TK Solver item, check the box next to the
desired items and click the “Insert Checked Items” button. You can easily select all inputs or all outputs by
checking the boxes next to “Check All Inputs” or “Check All Outputs” at the bottom of this window.

You can add text, images, headers and footers. Format your report as you would any Word document.
When you are finished creating your template, click “Save As” from the “File” toolbar. Select the desired
location to save your file. Type in a file name and click the “Save” button.
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Add a Galaxy Report

Choose “Galaxy Report” for a report generated within the galaxy program.
Enter a “Report Title” and the “Display Order” and click the “Add and Continue” button.

Click the “Application Data” tab to view the application specific data (e.g. Application Group, developer name,
version details etc). Check the box next to the pieces you wish to be in your report and drag them into the
report area.
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Similar to building a form, click the
button to view the data from the application. Check the
box next to the pieces you wish to be in your report and drag them into the report area.
Choose items from the “Toolbox” panel on the right side of the screen. Click on the desired item and drag it
into your form.
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Click

to edit properties for an individual field.

Click

to save your work periodically. Click
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Variable Description
Each Variable can be modified in Galaxy. You can change the description, set the default US/SI unit, set
min/max values, format types and number of decimals.

Click

to save changes.

User Access
Galaxy users that are specified here will have access to the current Galaxy application. To give access to a user,
click the “Add” button. To remove a person from the current application, click the “Delete” button.
Note: only current Galaxy users will be able to be added here. To add users into Galaxy, click on the “Tools”
menu and select “Users”. This is covered in more detail in the “Adding / Managing Galaxy Users” section of
this manual on page 34.

Application Created
Your application has been created. To learn how to use an application, please see the “Using a Galaxy
Application” section of this manual on page 49.
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Developing a Galaxy Application
Using an Excel Spreadsheet
Preparing the Excel Spreadsheet for Galaxy Application
Open the Excel spreadsheet that will be used with the Galaxy Application.
Highlight the cells that will be used in the Galaxy application and click the “Add Variables” button on the
“Galaxy Export Tool” Toolbar.

A new sheet named “GalaxyVariables” is created. If your spreadsheet uses multiple sheets, cells from each
sheet need to be added separately using the “Add Variables” button. Additional cells will be added to the
“GalaxyVariables” sheet.
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Save the Excel spreadsheet selecting File Type as “Microsoft Excel97-2003 Workbook.xls”.

Click “Save” and close Excel.

Log into Galaxy
Enter your User Name and Password and click “OK”.
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Creating a New Excel Application
On the Development menu, choose “Create New Excel WorkSheet Application”.

The remaining steps are similar to creating an application from a TK Solver model and are covered in the
previous section “Creating a New TK Solver Application” on page 6.
One additional step you must take when using an Excel WorkSheet is you must click the “Get Excel Data”
button after you choose your .XLS file.
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Developing a Galaxy Application
Using Scilab
On the Development menu, choose “Create New Scilab Application”.

The remaining steps are similar to creating an application from a TK Solver model and are covered in the
previous section “Creating a New TK Solver Application” on page 6.
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Edit an Existing Application
To make changes to the scenarios and forms of an existing application, choose “Edit an Existing Application”
from the “Development” menu.

The following screen appears:

Galaxy – UTS Knowledge Management System

Page 32 of 58

From the “Edit Application” screen, choose the Group your application is in, the application and the version
of that application you would like to make changes to.
Click the

button under “Application” to update the Application Group or the Application Name.

Click the

button under “Application Version” to update the version details.

Enter the Version Details and click
Click the
Click

.

button to delete the application.
and your application is loaded into Galaxy.

Now you may make changes to Scenarios, Documents, Forms, Reports, Variable Details, and User Access.
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Delete a Galaxy Application Version
To delete a version of a Galaxy Application you have created, choose “Edit an Existing Application” from the
“Development” menu. First select the “Application Group”, then the “Application” and finally the
“Application Version” you wish to delete. Now click the “Delete” button (below “Application Version”).
When prompted click the “Yes” button then the “Delete” button.

Delete a Galaxy Application
To delete a Galaxy Application you have created, choose “Edit an Existing Application” from the
“Development” menu. First select the “Application Group”, then the “Application” you wish to delete. Now
click the “Delete” button (below “Application”). When prompted click the “Yes” button then the “Delete”
button.
Note: you cannot delete an Application that contains any versions. In order to delete the application you must
first delete all versions.
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Adding / Managing Galaxy Users
Galaxy users can be added by selecting “Users” from the Tools menu.

A list of all current Galaxy users is shown. Here you can add new users, view or edit current users and delete
users.
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User Permissions
Permissions for each user can be set when the user is added by clicking the “Add” button in the “User”
window. An existing user can have permissions modified by clicking the “Edit” button.

Checkbox:

When checked means:

Active
Add User

The user is able to log in and use the software.
This user is able to add new users.

Add Customer
Administrator

This user is able to add customers.
This user can add users, change users, and change company
information. This user can delete and archive any user's designs.

Add Project
Add Corp Profile

This user is able to add a project.
This user is allowed to add corporate profiles.

Add New Galaxy Application (TK
Solver Model & Excel)
Create New Package

This user can add new applications using TK Solver models and Excel
worksheets.
This user can create a new package application.

Save Design
Save Profile

This user is able to save designs.
This user is able to save profiles.

Share Application
Show Solver

This user is able to share their own developed applications with other
users.
This user can view solver engine at runtime.

Create Scilab Application

This user can create an application using the Scilab solver engine.
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Dependency
Galaxy allows a user with “Administrator” privileges to view all applications, versions, design, profiles and
documents for any user. To access this information, choose “Users” from the “Tools” menu. Select the user
and click on the

button.
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Transferring Authorship of an Application
Galaxy allows a user with “Administrator” privileges to transfer ownership of an application to another user.
To transfer an application to another user, choose “Edit an Existing Application” from the “Development”
menu. Select the Application Group and choose the application. Click the “Transfer Authorship” button.

The “Transfer Application” window allows the Administrator to select a new user who will now be the author
of the current application.
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Adding and Managing Application
Groups
Users with “Administrator” privileges can add “Application Groups”. To add an Application Group, choose
“Application Group” from the “Development” menu.

Click the

button. Type the name of the new group and click the “Add” button.
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Assigning an Application Group to a User
Users with “Administrator” privileges can assign an Application Group to other users. To add an Application
Group to a user, choose “Users” from the “Tools” menu.

Choose the user you wish to assign to a group and click the
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Click the

button.

Select all applications you would like to associate with this user and click the “Save” button.
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Adding and Managing Document
Groups
Users with “Administrator” privileges can add “Document Groups”. To add a Document Group, choose
“Document Group” from the “Development” menu.

Click the
button.

button to create the new group. Type the name of the new group and click the “Add”
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Assigning a Document Group to a User
Users with “Administrator” privileges can assign a Document Group to other users. To add a Document
Group to a user, choose “Users” from the “Tools” menu.

Choose the user you wish to assign to a Document Group and click the
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Click the

button.

Select all Document Groups you would like to associate with this user and click the “Save” button.
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Packaging
Create a new Package
Packaging refers to using multiple source files to build a Galaxy Application. There is no limit to the number of
TK Solver models or Excel Spreadsheets that can be used to an Application. A combination of any amount of
.TKW files and .XLS files may also be used.
To begin a new application using Packaging, click on the “Development” menu and select “Create New
Package”.
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The following screen appears:

Select the “Package Group” that the new package will be in and type in a “Package Name” and a
“Description”.
Next, you will begin selecting the existing Galaxy applications that you wish to combine by selecting the
“Application Group”, “Application” and “Application Version” and clicking the “Add” button. The
application will be added to the list. Repeat this for each additional Galaxy applications you wish to include.
Then click the

button.

Next you will build Scenarios (page 9), Forms (page 12), Reports (page 22), and add User Access (page 27) in
the same way you do for Applications. See the previous sections in this manual regarding those elements.
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Edit an Existing Package
To make changes to an existing package, choose “Edit an Existing Package” from the “Development” menu.

You will see the following screen:

Select the group that the package is in and select the package then click the
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Add Document to Library
Documents can be added to the Document Library for later attachment to applications. Click on the
Development menu and select Add Document-> Library.

Document Group:

Select the group the document
will be in.
Document Type:
Select which type of file the
document is.
New Document:
Select this radio button if the
document is new.
Document Name: Enter the document name
(required if “New Document”
is selected).
Description:
Enter the document
description (required if “New
Document” is selected).
Existing Document: Select this radio button if you
are updating a currently existing
document.
Edit button:
Click this button to edit an
existing document’s Name,
Description, or Group.
Delete button:
Click this button to delete a
document from the library.
Version Information: Select the Version Number and
type in Version Details
(required if “New Document” is selected).
Link:
Select the Link radio button if the reference is a website.
File:
Select the File radio button then the
button to locate the desired file (required if
“New Document” is selected).
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Using a Galaxy Application
Log into Galaxy
Enter your User Name and Password and click “OK”.

Starting a New Design
After logging into the Galaxy application, you see the “Applications” window. If you have closed this window
you can return to it by choosing “Open Galaxy Application” from the File menu or by clicking the “Open
Galaxy Application” icon
on the toolbar.
Click the to expand the menu on the left. Choose your Application and version. Select your Scenario from
the dropdown box. If you use profiles, select your Global profile, Department profile and User profile. Click
.
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Searching for a Design
If you need help finding a design, select “Application Search” from the Tools menu. Here you can enter
different search criteria to help you find a particular application. Once the application is located, click
.

Commenting on a Design
Users can share comments regarding a design using the “Comments” dropdown box in the toolbar.

Clicking the dropdown box opens the “User Comments” window. Here you can add your comments and read
comments left by other users.
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Forms, Plots, Reports, and Documents
Forms, Plots, Reports and Documents can be selected from the dropdown lists.

Plot Options
Visual elements of plots may be changed in a Galaxy application. To make changes to a plot’s visual elements:
1. Open the plot from the “Plots” dropdown box.

2. Right click on the plot.
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Multiple Y-Axis
If a TK Solver Galaxy application has a plot with 2 or more series in it, you can view the plot with multiple YAxis. Right click on the plot and select “Enable Multiple Y-Axis”.
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Optimized Variables
To see a summary of optimized variables, choose “Show Optimizer” from the Tools menu. A list of optimized
variables appears.

Note: the bounds cannot be edited.

Save Design
Select “Save Design” from the “File” menu to save the Galaxy application with a different set of data.
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Open Design
Select “Open Design” from the “File” menu to open a previously saved Galaxy design. Enter search criteria
and click the search button.

All designs meeting the search criteria will be listed in the “Design” portion of the window. Choose a design
and click the “Open” button.
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Compare Designs
Click the
criteria.

button to see the differences between the designs that meet your search

Using Profiles
After you finalize a design, you can save it. If some or all of these variable values will be frequently required in
other designs, you can save such data sets as profiles and name them.
The profile concept permits the reuse of data for a particular set of parameters. Thus, instead of starting with a
blank input form, you can open a previously saved profile and use it as a starting point.
You can create as many new user-defined profiles as you wish. You can set values for whatever variables you
wish—some or all. The values can, if desired, be beyond limits set in the system variable. There will be no
conflict. The profile system is completely flexible.
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Adding a New Profile
To add a profile based on the current design, go to the File menu and select “Save as Profile”. Type a name for
the profile, select a profile type and click Save.

To edit a previously saved profile, go to the File menu and select Profiles. Choose the Application Group,
Application Type and Version the profile was assigned to. From the list of profiles in the lower section, select
the profile and click Edit. Default minimums and maximums can be set as desired. To establish these as firm
limits for a particular variable, click its “Firm Limits” checkbox.

If you want validation for minimum and maximum values, set a firm limit with the checkbox. If this box is
checked, the user of this profile will get an error message during calculations if the input data is outside the
specified range.
Once the profile values are set, save the profile by clicking the Save button.
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Administrative Functions
Sharing an Application
(Admin only) Select “Application Share” from the “Tools” menu to share an application with another end
user.

Application Code System
(Admin only) Select “Application Coding System” from the “Tools” menu. Click the “Add / Edit / Delete”
link to make changes to the Coding System dropdown boxes.

To add a new option, click in the empty line at the end and a Description and CodeID. To edit an existing
option, click in the field and make the desired changes.

Usage Data
(Admin only) Selecting “Usage Data” from the “Tools” will export a .dat file. This file will contain
information on Galaxy users and the time they have spent logged into the program.
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Export to Excel
(Admin only) Select “Export to Excel” from the “Tools” menu to generate an Excel spreadsheet listing
information regarding all Galaxy applications.
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